LincolnsOnLine.com


Home Forum Links Tech Rides Power Tour Gallery
Go Back   Lincolns OnLine Message Forum > Hot Rod Lincolns > Town Car > 1980 - 1989 Town Car
Register FAQ Calendar Mark Forums Read


Reply
 
Thread Tools
  #26  
Old September 15th, 2017, 01:12 PM
1980MarkVI 1980MarkVI is offline
Lincaholic
 
Join Date: July 31st, 2017
Location: Hayward/CA
Posts: 15
1980MarkVI is on a distinguished road
I checked the passages by applying vacuum to the EGR at idle and then engine died, so that's good. The EGR systems have been tested, including the solenoids. I have read that if your engine is running very lean then NO will be high no matter what.

If I interpreted the needle sweeps correctly, I pulled codes 12 and 22 last night.
12 is Engine RPM out of Spec
22 is Manifold absolute pressure sensor shorted or open

I'll put my old B/MAP sensor back in and try pulling the codes again to see if code 22 goes away.
Not sure what 12 is all about.
Could be cause my throttle kicker is bad and it's not increasing the RPM's much during the test? Anyone have more input on what 12 does.

And for those trying to catch up, after replacing the TPS a couple weeks ago, the car starts up right away, no need for starting fluid.

Last edited by 1980MarkVI; September 15th, 2017 at 01:24 PM.
Reply With Quote
  #27  
Old September 15th, 2017, 10:17 PM
gadget73's Avatar
gadget73 gadget73 is offline
Box Mod
 
Join Date: November 26th, 2004
Location: New Jersey
Posts: 15,064
gadget73 has a reputation beyond reputegadget73 has a reputation beyond reputegadget73 has a reputation beyond reputegadget73 has a reputation beyond reputegadget73 has a reputation beyond reputegadget73 has a reputation beyond reputegadget73 has a reputation beyond reputegadget73 has a reputation beyond reputegadget73 has a reputation beyond reputegadget73 has a reputation beyond reputegadget73 has a reputation beyond repute
The throttle kicker only does anything with the AC on, though I guess it might be tested during a self test. What rpm does it idle at?
__________________
86 Lincoln Town Car (Galactica) HO swap, BHPerformance E7 heads, Tmoss GT40 lower, CompCams XE258, Scorpion 1.72 RR, ASP underdrive pulley, big front brakes, rear disc brakes, 2002 CVPI steering box, all poly bushings, for more info, visit here

for the de-rusting project, see here

91 LSC SE, triple black, 2.25" exhaust by United Exhaust, Holley SystemMax 1 lower intake, 246k and counting
Reply With Quote
  #28  
Old September 18th, 2017, 11:36 PM
1980MarkVI 1980MarkVI is offline
Lincaholic
 
Join Date: July 31st, 2017
Location: Hayward/CA
Posts: 15
1980MarkVI is on a distinguished road
Thanks for all your help so far Gadget!
I don't have a tach, so I have no idea what the idle RPM is.

Here's a good video of the EEC-III test procedure:
https://www.youtube.com/watch?v=puAEJ3BYFeY

In the video the Lincoln revs up, assuming via the throttle kicker, and mine doesn't. The vacuum diaphragm is shot on my idle stop / kicker, it doesn't hold vacuum so the ECU can't bump up the idle for the test. I believe that's why I'm getting code 12. I found a replacement online for $40, I think it's maybe worth swapping it out.

I'm still getting the code 22 for the MAP sensor, and this is for the old sensor and the new. I'll have to retest both this week and watch the voltage drop as I apply vacuum. I guess I could also be getting the code 22 because during the test it can't bump up the idle and therefore the MAP sensor isn't changing it's output during the part of the test. I'm not sure exactly what it is testing on the sensor, but in my previous tests with a multimeter it appears to be working.

I'm also going to hook up my multimeter to the EGR's position sensor and drive around with the multimeter taped on my windshield. Hoping to see the voltage fluctuate normally as the EGR opens and closes. Or I should say I'm hoping for it to NOT open so I know what is causing the high NOx! I could not get the EGR to open just by revving the engine as it sat in park...
Reply With Quote
  #29  
Old September 19th, 2017, 04:27 PM
gadget73's Avatar
gadget73 gadget73 is offline
Box Mod
 
Join Date: November 26th, 2004
Location: New Jersey
Posts: 15,064
gadget73 has a reputation beyond reputegadget73 has a reputation beyond reputegadget73 has a reputation beyond reputegadget73 has a reputation beyond reputegadget73 has a reputation beyond reputegadget73 has a reputation beyond reputegadget73 has a reputation beyond reputegadget73 has a reputation beyond reputegadget73 has a reputation beyond reputegadget73 has a reputation beyond reputegadget73 has a reputation beyond repute
yeah its supposed to see the engine warmed up and running at partial load before it opens.
__________________
86 Lincoln Town Car (Galactica) HO swap, BHPerformance E7 heads, Tmoss GT40 lower, CompCams XE258, Scorpion 1.72 RR, ASP underdrive pulley, big front brakes, rear disc brakes, 2002 CVPI steering box, all poly bushings, for more info, visit here

for the de-rusting project, see here

91 LSC SE, triple black, 2.25" exhaust by United Exhaust, Holley SystemMax 1 lower intake, 246k and counting
Reply With Quote
Reply

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:15 PM.



Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.


LincolnsOnLine.com is not affiliated with Ford Motor Company or
the Lincoln Motor Company. Unauthorized duplication strictly prohibited.



Copyright 1999-2017 LincolnsOnLine.com